Browser extension: Loading issue, and Records in Team shared folders not appearing.
Incident Report for Keeper Status Page
Resolved
We have resolved this issue (auto-fill for Team Folders) and published version 12.6.3 to Chrome, Firefox and Edge extension app stores. Chrome and Firefox will auto-update within the hour or you can visit the Extensions screen to check for update. Edge will be approved by Microsoft within 24 hours.
Posted Dec 10, 2019 - 15:37 PST
Investigating
We are aware of a bug in the latest browser extension related to filling passwords that are stored in a team shared folder. We are publishing a fix to the app stores shortly however due to Google's new review process it may take up to 12 hours to publish the update.

Improvements were also made in regards to auto-login between Web Vault and browser extension. To ensure you have the latest Web App please open the Web Vault and reload your browser (Shift+Reload) or clear cache. This resolves any frozen pages or login issues between components.

Affected browsers: Chrome, Firefox, Edge
Not affected: Safari
Posted Dec 10, 2019 - 07:27 PST
This incident affected: End-User Client Applications (Keeper Browser Extensions).